In the beginning of the year 2011, we decided to apply IPv6 configuration to our data center (VeriTeknik) and requested our IPv6 block from RIPE. RIRs give out /32 blocks to LIRs at the first assignment.

The Preperation Steps

  1. Request your IPv6 Addresses from your RIR or LIR
  2. Add IPv6 Route to your AS number in LIR Portal
  3. Get your IPv6 VLAN IP from your Upstrem Provider
  4. Configure your router

 

Configuring Cisco Routers for IPv6

 

Before you start applying IPv6 on your routers make sure that you backup your current configuration.

First of all, make a table of your arguments such as your IP addresses, AS numbers etc like below, we put some values for you to easly analyze the configuration:

Your AS Number AS65535
Remote As Number AS1000
VLAN IP Your Side (Given by Telco op) 2A01:358:4500:2::2/64
VLAN IP remote Side (Telco Side) 2A01:358:4500:2::1
Your IPv6 Addresses to Annnounce 2B00:7300::/32

Enable IPv6 & IPv6 cef on your Cisco router:

ipv6 unicast-routing
ipv6 cef
!

Set your IPv6 address to the interface facing telco:

Don’t delete your IPv4 configuration or other necessary codes, just add

interface GigabitEthernet0/0
description $ETH-WAN$
ipv6 address 2A01:358:4500:2::2/64
ipv6 enable
ipv6 virtual-reassembly
..
..
!

Switch to BGP configuration by typing “router bgp 65535”

add:

router bgp 65535
.
.
neighbor 2A01:358:4500:2::1 remote-as 1000
!

type exit and type address-family ipv6 to enter IPv6 configuration

to announce your prefixes type:

address-family ipv6
neighbor 2A01:358:4500:2::1 activate
distance bgp 200 200 200
network 2B00:7300::/32
network 2B00:7300:100::/48
redistribute connected
redistribute static
no synchronization
exit-address-family
!

Type exit one more and you need to add routes for your IPv6 addresses,

ipv6 route 2B00:7300::/32 Null0 254

This is the basic IPv6 configuration for Cisco routers, now you should be able to communicate with IPv6 enabled hosts. To test your configuration you may assign IPv6 to one of your VLANs, an example given below:

interface GigabitEthernet0/1.201
description LOCAL
encapsulation dot1Q 201
.
.
ipv6 address 2B00:7300:100::1/48
!

Leave a Reply

Your email address will not be published. Required fields are marked *